Alert and LoadingSpinner don't show up behind apache forward

I have the following setup:
(panel server: localhost:5006) <-----> (apache reverseproxy: *:80) <------> (clients)

and I just added two panel components that don’t show up in the browser, even though they work fine when looking at the panel page on localhost:5006 directly.

  • LoadingSpinner: doesn’t show up at all
  • Alert: the text shows up, but not the background and box

Do they need an extra ProxyPass entry or something similar?

This is my apache conf:

ProxyPreserveHost On
ProxyPass /myapp/ws ws://localhost:5006/ws
ProxyPassReverse /myapp/ws ws://localhost:5006/ws

ProxyPass /myapp/ http://localhost:5006/
ProxyPassReverse /myapp/ http://localhost:5006/

Redirect /myapp https://myserver/myapp/

In my browser I get

[HTTP/1.1 404 Not Found 12ms]GEThttps://myserver/static/extensions/panel/css/widgets.css
[HTTP/1.1 404 Not Found 45ms]

It should probably look at https://myserver/myapp/static, so somewhere the root url is wrongly set.

I can make it work by adding this to the apache conf:

Redirect /static http://myserver/myapp/static

But I think it should be possible to tell panel about the root url.

1 Like

Hi @nritsche

I have not tried changing the base url yet. But I will soon so I also want to learn this.

I will share the knowledge/ ideas I have. Maybe it can help.

I believe that for static assets there are two solutions.

  • Change the proxy configuration as you do above or
  • Change the base url of the site.

The base url should also help for relative urls to other pages in the site. Not only the static assets. I have not tried this yet.

You can add the base url using a custom template or using one of the new BasicTemplates like VanillaTemplate etc. They have a parameter called base_url. See I have not tried this yet.

If you try some of this out please let me know if it works or not. Thanks.

It looks like my issue was actually caused by this bug ( and fixed here (

I think the base url option will be useful for me anyways, though. Thanks @Marc

1 Like