#403 errors quarto and panel

Hi. I am trying to add a quarto blog to my panel app . The quarto blog runs fine on the local machine on a stand alone basis.

I have linked the blog directory to the panel app using the following:
panel serve --port=80 --allow-websocket-origin=xxx.ipynb --static-dirs assets=“/Users/xxx/_site”
and there is an href in the panel template to link to the static assets.

The front page of the blog loads fine but I get a #403 “forbidden” when clicking on any of the posts links. I cannot see any obvious errors with the unix(mac) permissions for the directories and files

I am wondering if there are any of panel serve options I need to set such as including the posts directory in the assets list?

The underlying panel app is working great to display and interact with the data but I’d definitely like to add in the blog (analysis articles).

to be clear after working on the files all day it seems that the --static-dirs assets = only resolves to the top directory in the tree. The posts which are in a subdirectory are not resolved in either safari or chrome so that the browser doesn’t see the relevant index.html file but only the directory. When clicking on a posts link the browser window shows something like http://www.abc.com/assets/posts/Looking_forward/)” when it should show and does show when run by itself http://www.abc.com/assets/posts/Looking_forward/.index.html”.

If i edit the browser window to include the index.html slug then the page loads correctly.