Bokeh throwing strange errors in browser console

Hello folks,

I have set up my panel dashboard, and it is looking good, and does not throw any errors into Python console when I change some widget values (and my Bokeh plots updated as a consequence of that). However, what does bother me still is this strange behavior:

a-i) The app instantiates a few default values and populates Bokeh plots with them upon the session start. None of that is followed by console errors.

a-ii) I have also noticed a sneaky css issue upon the session start - wonder if that causes trouble (I do use a non-default template, and according to Templates documentation on panel webpage I thought CSS do not have to be duplicated locally in static) ?:

b) whevener I select a different value of a widget (e.g. that involves pulling data for a different group of measurements), the bokeh plots are updated accordingly. But the JS console is then contaminated with 100+ errors of the same kind, that are difficult to debug:

They are pretty much identical, and I am not sure whether that is a big deal or not. They seem to happen on both local and remote deployment. As opposed to local deployment though, on my remote deployment they are usually followed (~with 5-10s delay) of a Websocket connection drop with error 1006. At this point it is difficult to understand what 1006 can be related to, but likely not to this (as it happens after all data is delivered, and plots updated):

Could you also report the Panel and Bokeh versions you are using? It sounds like you are on a Panel dev version.

Apologies… I am on a Panel’s master branch as of commit:
panel @ git+

I was pretty excited to use the Tabulator, hence decided to go full-steam ahead of the next release :slight_smile:

1 Like

I think you will need to

Install the latest development version of bokeh

pip install bokeh==2.3.0.dev12

build panel (this requires node.js)

panel build panel

open the app/ notebook and finally do a hard refresh of your browser.

Thanks Marc, will try it today and let you know!

1 Like

I’ll be tagging a dev release tomorrow.

1 Like

I decided to go all in and attach the authentication to my panel app, as well as update it today (since Auth0 was recently added).

I noticed you were in high-intensity commit mode today, @philippjfr :), so I shall be able to update you on the status of those weird errors soon after I update the reqs and pin to one of your recent succesful commits to master.

It looks like that the static for templates is not pulled in properly somehow, and Bokeh screams about DOM Exception in the browser console.

We also tend to see websocket connection drop, but the suspicion there is our VPN that might be dropping some messages in the socket due to the protocol it uses.

Which Bokeh version is that?

It is:
I also noticed Panel is trying to go for statics into my local-to-app static folder (to get bootstrap template js files), instead of its own folders. Is this expected ?

That doesn’t seem right. Will need to investigate.

So I tried installing the hot bleeeding edge master versions, and while everything installs properly (bokeh dev release is picked up), the panel app itself struggles to arrange elements.

Specifically, I still see DOMException as per the image above, and all my widgets piled up on top of each other in the upper left corner of the body part of the Bootstrap Template I am using. The sidebar seems to be rendered correctly though.

EDIT: Last commit to master fixed it! Big thanks @philippjfr !!!

1 Like