Downgrading from V1.3.0 to V1.1.1

panel can no longer be served after being downgraded from v1.3 to v1.1.1 and any other library less than v1.3. The following error:

  File "C:...\AppData\Local\Programs\Python\Python310\lib\", line 187, in _run_module_as_main
    mod_name, mod_spec, code = _get_module_details(mod_name, _Error)
  File "C:...\AppData\Local\Programs\Python\Python310\lib\", line 146, in _get_module_details
    return _get_module_details(pkg_main_name, error)
  File "C:...\sabiyounes\AppData\Local\Programs\Python\Python310\lib\", line 110, in _get_module_details
  File "C:...\AppData\Roaming\Python\Python310\site-packages\panel\", line 48, in <module>
    from . import layout  # noqa
  File "C:...\AppData\Roaming\Python\Python310\site-packages\panel\layout\", line 31, in <module>
    from .accordion import Accordion  # noqa
  File "C:...\AppData\Roaming\Python\Python310\site-packages\panel\layout\", line 11, in <module>
    from ..reactive import Reactive
  File "C:...\AppData\Roaming\Python\Python310\site-packages\panel\", line 36, in <module>
    from .io.document import unlocked
  File "C:...\AppData\Roaming\Python\Python310\site-packages\panel\io\", line 9, in <module>
    from .document import init_doc, unlocked, with_lock  # noqa
  File "C:...\AppData\Roaming\Python\Python310\site-packages\panel\io\", line 25, in <module>
    from ..config import config
  File "C:...\AppData\Roaming\Python\Python310\site-packages\panel\", line 548, in <module>
    config = _config(**{k: None if p.allow_None else getattr(_config, k)
  File "C:...\AppData\Roaming\Python\Python310\site-packages\panel\", line 307, in __init__
  File "C:...\AppData\Local\Programs\Python\Python310\lib\site-packages\param\", line 4139, in __init__
    if not isinstance(self._param__private, _InstancePrivate):
  File "C:...\AppData\Roaming\Python\Python310\site-packages\panel\", line 392, in __getattribute__
    init = super().__getattribute__('initialized')
AttributeError: '_config' object has no attribute 'initialized'

Hi @simonay

I would suspect this to be due to some other library like Param or Bokeh that also needs to be downgraded. The easiest is to recreate the environment. If the issue still persists its a bug and should be reported on Github.

Hi Marc,

Thanks! Can you please share what versions should the Param and Bokeh libraries be in for Panel 1.2 and Panel 1.1. I actually created a new virtual environment where I install primarily Panel 1.2.0 and it crashes from the beginning upon serving my original script.

Hi @simonay

If you have created your environment from scratch, then you should get a working environment. It seems you don’t. Then please report this on Github with the steps that can reproduce the issue. Including a minimum code example. Because it might also be your code using functionality that is available in latest Panel but not in Panel 1.1.


Hi @Marc ,

I will do that straight Monday morning. Will keep you posted, thanks.

1 Like

This indicates that you have param 2.0 which is unfortunately not compatible with older versions of Panel.

1 Like

The thing is I’m not installing Param library manually. It comes with the Panel installation. However, which Param library would you recommend?

Just pin it to param<2. Unfortunately there is no way for us to retroactively update the pins for old panel versions.

It worked! I installed param v1.13.0 and the webapp served back normally pn panel v1.2.0, thanks.

1 Like