Framewise=True doesn't work in a layout with tabs

Hi everyone. I’ve been trying to get a HoloView Curve to update framewise in response to a bunch of tabs and a radiobuttongroup. Setting the opts.Curve(framewise=True) works for the radiobuttongroup, but has no effect on the tabs. How can I get the y-axis range to adjust for the different tabs?

Here is the code I used so far, with holo_df being a pandas DataFrame, kdims being a list with 3 key dimensions and vdims a list with 2 value dimensions.

intervals = list(holo_df[kdims[2]].unique())
intervals = pn.widgets.RadioButtonGroup(options=intervals, name=kdims[2], align='center')
holo_ds = hv.Dataset(holo_df, kdims, vdims)
plot =, kdims[0], vdims[0])
plot = plot.opts(opts.Curve(framewise=True, tools=['hover'], aspect=2/1, responsive=True))
pan = plot.layout(kdims[1]).opts(tabs=True, framewise=True)
pan = pn.panel(pan, widgets={kdims[2]: intervals})
pn.Column(f"## {kdims[1]} {vdims[0]} per {kdims[2]}",
                     pn.Row(pn.layout.HSpacer(), pan[1][0], pn.layout.HSpacer()),

Thanks for your help!

Maybe Combine DynamicMaps without linking - #2 by Marc

Thanks a lot for the tip! The linked_axes=False produced an error, however, this led me to finding the shared_axes=False argument, which in turn did the trick.

pan = plot.layout(kdims[1]).opts(tabs=True, shared_axes=False)