Installing Datashader on ARM aarch64

I am trying to install datashader via conda in aarch64 using command “conda install datashader” and failing with below error logs.

root@d0cce880d2ba:/# conda install datashader
Solving environment: failed

PackagesNotFoundError: The following packages are not available from current channels:

  • datashader
  • bokeh
  • datashader
  • dask[version=’>=0.18.0’]
  • datashader
  • numba[version=’>=0.37.0’]
  • datashader
  • scikit-image

Current channels:

To search for alternate channels that may provide the conda package you’re
looking for, navigate to

and use the search bar at the top of the page.

Can anyone help me with this issue?

Datashader requires up to date numba and in turn llvm-lite that I don’t think are available as conda packages for ARM, so I’m pretty sure that you can’t install it in any reasonable way on that architecture. The scikit-image and bokeh dependencies aren’t important at all, and the dask one can probably be worked around, but I don’t think it’s reasonable to try to run Datashader without Numba…

There are ARM builds of numba on the numba channel.

I had thought those were outdated builds from an old project, but it does look like they are up to date now, so maybe there is a chance! I’ll ask the Numba team about the status of aarch64. Dask is the next thing to track down, but in principle it should be possible to make it runnable without dask. So while ARM and specifically aarch64 are not supported platforms (only those listed under Build Status on are), it may be feasible to get it working. If so, let us know here as a recipe for others!

From :

"Conda-forge support for AArch64 is still quite experimental and packages are limited, but it does work enough for Numba to build and pass tests. "

Sounds like it’s worth a shot!

Hi Jbednar,

Thanks for the quick reply!

I tried to install datashader via conda after resolving few dependencies. The command “conda install datashader” is installing “datashader==0.6.5” but not higher version or the latest. Can you please help me to understand the reason behind it and when I will be able to install latest datashader via conda.

To get things installed so that you can test them, I’d just use conda install --no-deps -c pyviz datashader. Ordinarily, that would be a command to avoid, because it ignores the dependencies and version restrictions, but in this case no one has tested Datashader on aarch64, so you’re already on your own anyway, and this will let you debug things.

As per your suggestion I tried installing datashader by the command “conda install --no-deps -c pyviz datashader” and failed with below error-

#conda install --no-deps -c pyviz datashader
Solving environment: …working… failed
PackagesNotFoundError: The following packages are not available from current channels:

However, after resolving numba and testpath dependency(using command - “conda install -c numba numba” and “conda install -c anaconda testpath”), datashader version “0.6.5” is getting installed not the latest one.

Could you please help me installing latest version for datashader.

Whenever you have a problem getting an outdated version, try looking up what the most recent version is (at the github releases page, or at, then pin it explicitly: conda install --no-deps -c numba -c pyviz datashader=0.10.0