Interactive Matplotlib panes do not show up in lab/notebook

Hey there!

I’ve been going through the matplotlib pane documentation and tried to run through the examples provided in Matplotlib — Panel v0.14.1, but none of the plots show up when I use the interactive=True input when creating the Matplotlib pane object. The same behavior occurs both in Jupyter notebook and lab.

If I grab the ipywidget-managed canvas object from ipympl tucked away in there and render it in a separate cell, the interactive plot does show up.

I also noticed is that if I grab that ipywidget object, place it in an IPyWidget pane and call .param.trigger('object'), then the plot shows up in the previous cell holding the once-empty Matplotlib pane.

Is anybody seeing the same thing or able to reproduce the issue or know of a work around?

Here’s what’s in my current environment that I figured would be most relevant:

jupyterlab 3.5.0
notebook 6.5.1
panel 0.14.0
matplotlib 3.6.1
ipympl 0.9.2
ipywidgets 8.0.2 [also tried 7.7.1]
ipywidgets_bokeh 1.2.1
jupyter_bokeh 3.0.5
bokeh 2.4.3 [also tried 2.4.2]
pyviz_comms 2.2.1

BTW, I love the Matplotlib pane feature and was super excited when it was added. It has been a huge help in moving pre-existing matplotlib projects over into a Panel pane and hook them up to other Panel widgets and panes. So… whoever that is, thank you!

1 Like

I think this is a bug. Could you report the issue on Github? Please include a minimum, reproducible example and some screenshots. That will make it possible to try to replicate.