Is there no HoloViz installation via pip?

All documentation seems focused on installing HoloViz via conda. I want to install it with pip.

If I do pip install holoviz will I get the same thing?

Also, I could not find an appropriate category for this question in the category list, so I put it in HoloViews (apologies if that’s not the best choice).

Thanks!

In an Ubuntu 20.04 test container with python 3.8.10 I did “pip install --user holoviz” and I got these packages installed:

Successfully installed Jinja2-3.0.1 MarkupSafe-2.0.1 PyYAML-5.4.1 Send2Trash-1.8.0 argon2-cffi-20.1.0 attrs-21.2.0 backcall-0.2.0 bleach-4.0.0 bokeh-2.0.2 cffi-1.14.6 click-8.0.1 cloudpickle-1.6.0 colorcet-2.0.6 cycler-0.10.0 dask-2.17.2 datashader-0.11.1 datashape-0.5.2 debugpy-1.4.1 decorator-5.0.9 defusedxml-0.7.1 distributed-2021.8.0 entrypoints-0.3 fsspec-2021.7.0 heapdict-1.0.1 holoviews-1.13.5 holoviz-0.11.6 hvplot-0.6.0 ipykernel-6.2.0 ipython-7.26.0 ipython-genutils-0.2.0 jedi-0.18.0 jsonschema-3.2.0 jupyter-client-6.1.12 jupyter-core-4.7.1 jupyterlab-pygments-0.1.2 kiwisolver-1.3.1 llvmlite-0.36.0 locket-0.2.1 markdown-3.3.4 matplotlib-3.1.3 matplotlib-inline-0.1.2 mistune-0.8.4 msgpack-1.0.2 multipledispatch-0.6.0 nbclient-0.5.4 nbconvert-6.1.0 nbformat-5.1.3 nest-asyncio-1.5.1 notebook-6.4.3 numba-0.53.1 numpy-1.18.1 packaging-21.0 pandas-1.0.3 pandocfilters-1.4.3 panel-0.12.1 param-1.11.1 parso-0.8.2 partd-1.2.0 pexpect-4.8.0 pickleshare-0.7.5 pillow-8.3.1 prometheus-client-0.11.0 prompt-toolkit-3.0.19 psutil-5.8.0 ptyprocess-0.7.0 pycparser-2.20 pyct-0.4.8 pygments-2.10.0 pyparsing-2.4.7 pyrsistent-0.18.0 python-dateutil-2.8.2 pytz-2021.1 pyviz-comms-2.1.0 pyzmq-22.2.1 rise-5.7.1 scipy-1.7.1 sortedcontainers-2.4.0 tblib-1.7.0 terminado-0.11.0 testpath-0.5.0 toolz-0.11.1 tornado-6.1 tqdm-4.62.1 traitlets-5.0.5 typing-extensions-3.10.0.0 wcwidth-0.2.5 webencodings-0.5.1 xarray-0.15.1 zict-2.0.0

I also got these errors:

ERROR: distributed 2021.8.0 has requirement dask==2021.08.0, but you’ll have dask 2.17.2 which is incompatible.
ERROR: datashader 0.11.1 has requirement pyct[cmd]==0.4.6, but you’ll have pyct 0.4.8 which is incompatible.
ERROR: panel 0.12.1 has requirement bokeh<2.4.0,>=2.3.0, but you’ll have bokeh 2.0.2 which is incompatible.

Does it look more or less okay?

Regarding the errors: what is the possible impact from that?

Alternatively, I’ve installed Miniconda in an Ubuntu 20.04 container, and tried to install each project separately (I know pyviz is redundant):

conda install -c pyviz panel
conda install -c pyviz hvplot
conda install -c pyviz holoviews bokeh
conda install -c pyviz geoviews

But the last one errored out:

UnsatisfiableError: The following specifications were found to be incompatible with each other:

Output in format: Requested package -> Available versionsThe following specifications were found to be incompatible with your system:

  - feature:/linux-64::__glibc==2.31=0
  - python=3.9 -> libgcc-ng[version='>=7.5.0'] -> __glibc[version='>=2.17']

Your installed version is: 2.31

Finally, on a Windows 10 system I’ve created a new conda environment, and then I did this:

conda install -c pyviz holoviz

It succeeded, and it installed all HoloViz packages except for GeoViews.

Questions:

On the main Install page, shouldn’t this command be shown as THE way to install HoloViz? As opposed to showing how to install some tutorial project.

How to get GeoViews installed along with everything else?

conda install -c conda-forge cartopy
pip install holoviews
pip install geoviews
pip install hvplot
pip install panel

Hi @FlorinAndrei

Welcome to the community. I can see the HoloViz package 0.11.6 is more than a year old and totally outdated. I’ve reported it as a bug here holoviz package outdated · Issue #296 · holoviz/holoviz (github.com).

You can try installing pip install holoviz==0.12.0 as I can see there is a dev version of this released 28days ago. I have not tried this my self.

Otherwise try following @ahuang11 instructions. And report back here if you need more help.

This sequence worked and installed all HoloViz packages without obvious errors, using a new conda environment:

conda install -c conda-forge cartopy
pip install holoviews
pip install geoviews
pip install hvplot
pip install datashader

I think the main install.html page on the HoloViz website should have a working procedure, such as this one. That page does not contain a viable installation procedure for HoloViz. It is confusing for new users.

Anyway, then I had major issues trying to run Jupyter (installed from pip) from the same environment. I’ll start over and try something different.

Okay, the Jupyter problem was fixed by installing Jupyter from conda:

conda install -c conda-forge notebook

However, after that I tried pip install holoviz - and wow, it downloaded a lot of old packages, overriding my newer versions.

Starting over again, lol.

Okay, what seems to provide a drama-free installation on Win10 is this sequence:

Create and activate a fresh conda environment.

Run these commands in the new environment:

conda install -c conda-forge cartopy
pip install holoviews geoviews hvplot datashader
conda install -c conda-forge notebook
pip install $YOUR_OTHER_MODULES

Do not install holoviz from pip.

I’ll start playing with the visualization modules tomorrow. Thanks!

1 Like