My hvplot is broken after conda update --all

I did conda update --all today and now hvplot seems broken. Anybody recognize this problem?

(pangeo) rsignell@Elio:~$ conda list | grep -E "bokeh|pyviz|widgets|hvplot|geoviews|holoviews|panel"
bokeh                     3.4.1              pyhd8ed1ab_0    conda-forge
geoviews                  1.12.0             pyhd8ed1ab_0    conda-forge
geoviews-core             1.12.0             pyha770c72_0    conda-forge
holoviews                 1.18.3             pyhd8ed1ab_0    conda-forge
hvplot                    0.10.0             pyhd8ed1ab_0    conda-forge
ipywidgets                8.1.3              pyhd8ed1ab_0    conda-forge
jupyter-panel-proxy       0.1.0                      py_0    conda-forge
jupyter_bokeh             4.0.4              pyhd8ed1ab_0    conda-forge
jupyterlab_widgets        3.0.11             pyhd8ed1ab_0    conda-forge
panel                     1.4.3              pyhd8ed1ab_0    conda-forge
pyviz_comms               3.0.2              pyhd8ed1ab_1    conda-forge
widgetsnbextension        4.0.11             pyhd8ed1ab_0    conda-forge

It seems to be the same issue as some widgets like CrossSelector and MultiSelect broken in 1.4.3 · Issue #6865 · holoviz/panel · GitHub

Just updated everything to the same versions as you and updated conda. I have no issues, but I also don’t have jupyter-panel-proxy installed. My understanding is the proxy server is only launched when you try to visit the corresponding endpoint, but is it possible there are some other interactions?

I tried removing jupyter-panel-proxy but still have same problem.

It’s not clear to me from that issue what packages I should try downgrading. Do you know?

These are my versions:

bokeh                     3.4.0                    pypi_0    pypi
geoviews                  1.12.0                   pypi_0    pypi
holoviews                 1.18.3                   pypi_0    pypi
hvplot                    0.10.0                   pypi_0    pypi
ipywidgets                8.1.1              pyhd8ed1ab_0    conda-forge
ipywidgets_bokeh          1.5.0                      py_0    bokeh
jupyter-bokeh             4.0.4                    pypi_0    pypi
jupyterlab_widgets        3.0.9              pyhd8ed1ab_0    conda-forge
panel                     1.4.0a3.post201+gdefe76aa.dirty          pypi_0    pypi
panel-chat-examples       0.0.0                    pypi_0    pypi
pyviz_comms               2.3.2                      py_0    pyviz/label/dev
widgetsnbextension        4.0.9              pyhd8ed1ab_0    conda-forge

Try downgrading Panel to 1.4.2.

I tried downgrading panel to 1.4.2, but didn’t work.
And I’m confused: I’m only using hvplot – why is panel even involved?

Aha! Downgrading to pyviz_comms==2.3.2 fixed the problem for me. Thanks @ahuang11 !

Panel handles the communication between Python and Jupyter. Also what makes the widgets.

Ah, okay! While we are at it, what does pyviz_comms do? That sounds like communication also!

Hmm, testing Jupyter lab and downgrading pyviz_comms doesn’t seem to work for me.

After testing a lot of package variations, pinning pip install panel!=1.4.3 works.

See this issue