Panel: error when importing package

Hi,

I just installed Panel package and it is giving me an error on a very simple import line of code:

import panel as pn

The error I’m getting is the following:


File “C:\Users\joaonunes\AppData\Local\Continuum\anaconda3\lib\site-packages\panel\config.py”, line 116, in init
for p in self.param:

TypeError: ‘Parameters’ object is not iterable


Do you have any idea why this is happening?

For your reference:

  • I am running Anaconda on Windows 10 64-bit
  • I am running Panel [noarch/panel-0.9.5-py_1.tar.bz2], but I also tried it with other versions and the same error appears.
  • I am running python 3.7.4

You appear to have an old version of param. Param is pinned so I don’t know how that could happen, but please try upgrading the param package to >1.9

Humm, I can’t find version 1.9 or higher on the Anaconda repository at: https://anaconda.org/anaconda/param/files

I need to install offline because I am behind a firewall and trying to do the regular conda install command doesn’t work due to ssh issues.

It’s there, have a look on the second page: https://anaconda.org/anaconda/param/files?page=2

Anaconda.org seems to have rebuilt all old packages recently so the noarch packages are showing up after all the older platform specific builds.

Great, Phillipp! Found it, not it works!

1 Like

“Now it works”, I mean.

2 Likes