Panel Stopped Dynamically updating after updating dask packages

These were the package versions that worked before updating dask and distributed:

  • bokeh=1.4.0
  • dask=2021.2.0
  • datashader=0.12.1
  • distributed=2021.2.0
  • holoviews=1.12.7
  • matplotlib-base=3.2
  • panel=0.8.0

I am running the code through jupyter notebook as I couldn’t get dynamic visualization working in VS code.

All I did was update the versions of dask and distributed to 2021.4.1 and left the rest of the packages the same. The code runs fine until I try to run the following line:

if True:
    vaviewer = VArrayViewer(varr, framerate=20, summary=["mean"])

the show() function just returns the panel object:

return pn.layout.Column(self.widgets, self.pnplot)

When I click on the play button, the panel does not dynamically display new frames it just stays stuck on the first frame:

Since I am returning the panel to be visualized I am not receiving any errors, nor am I able to debug why the image is not updating.

Any help would be very appreciated.

Thank you in advance!

Edit: I managed to get the following output from the chrome console when trying to press play:

Python failed with the following traceback: 
C:\ProgramData\miniconda\envs\minian_updated\lib\site-packages\pyviz_comms\ _handle_msg L340
C:\ProgramData\miniconda\envs\minian_updated\lib\site-packages\holoviews\plotting\bokeh\ on_msg L126
C:\ProgramData\miniconda\envs\minian_updated\lib\site-packages\holoviews\ update L408
C:\ProgramData\miniconda\envs\minian_updated\lib\site-packages\holoviews\ _set_stream_parameters L390
C:\ProgramData\miniconda\envs\minian_updated\lib\site-packages\param\ set_param L1356
	ValueError: '_buffers' is not a parameter of PlotSize01458

Hi @GrowlingM1ke

Welcome to the community. Is there any chance you could try to update to latest versions of the packages? It might work. And if not it would be easier for someone to try to help out.

Hi @Marc,

Thank you for your response. Unfortunately, the project I’m working with is quite large and has many dependencies, which are almost 3 years old at this point. I’ve tried some time ago updating to the latest packages, however I realized that would require some significant code refactoring. Hence I was hoping to fix this issue by doing incremental updates to just two packages.