Turning off border when saving a GeoOverlayPlot with renderer

Hi There,
I am trying to clear the bounding box from plots I am saving to png files. I can crop with various tools, but was curious if there is a way to do this within the plots so I don’t have to do that while doing lots of image outputting/adjusting. Have been using a matplotlib renderer to save the plots.

I have tried a variety of options to .opts() to try and turn it off, including show_frame=False, different options for fig_bounds, and some others such as xaxis, yaxis, padding, but can’t get rid of the bounding box that shows up.

The result is something like this (the outer box is what I am trying to get rid of):

I would swap over to bokeh rendering and save with that because I can clear the box there, but then I get some artifacts within the plot that I cannot readily get rid of:

Any ideas on a way to solve either of these issues would be welcome.

If you know how to do it in matplotlib alone, you can use hooks or backend_opts:

That did it, was able to remove it with the backend_opts:

        "axes.frame_on": False,


A note for anyone else, the show_frame=False option did not work, so it is probably targeting something else.

1 Like

For the bokeh one, if it’s a public dataset maybe you can submit an issue to GeoViews.

I will look into doing that - see if I can duplicate that same issue with direct use of bokeh