Unable to update with newest panel, creating a new environment not straightforward

Although listed under conda search -c pyviz panel, I am unable to either update panel nor create a new environment. I want to use python 3.7 with bokeh 2.0, however the conda error message doesn’t show the list of problematic packages!

>conda create -n pyviztest python=3.7 bokeh
(works fine)

>conda activate pyviztest

> conda install -c pyviz panel

(suggests 0.7, so I cancelled)

> conda install -c pyviz panel=0.9.1

Collecting package metadata (current_repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: /
Found conflicts! Looking for incompatible packages.
This can take several minutes. Press CTRL-C to abort.
failed

UnsatisfiableError: The following specifications were found to be incompatible with each other:

Output in format: Requested package -> Available versions

As you can see, not showing the conflicts.

If trying to create directly
>conda create -n pyviztest2 python=3.7 panel=0.9.1

Collecting package metadata (current_repodata.json): done
Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): done
Solving environment:
Found conflicts! Looking for incompatible packages.
This can take several minutes. Press CTRL-C to abort.
failed

UnsatisfiableError: The following specifications were found to be incompatible with each other:

Output in format: Requested package -> Available versions

Package python conflicts for:
panel=0.9.1 -> python[version=’>=2.7’]
python=3.7
panel=0.9.1 -> bokeh[version=’>=2.0.0’] -> python[version=’>=2.7,<2.8.0a0|>=3.6,<3.7.0a0|>=3.7,<3.8.0a0|>=3.8,<3.9.0a0|>=3.5,<3.6.0a0’]

It shows more information, although it makes little sense to me. Isn’t python 3.7 >= python 3.7?

Without mentioning python version:

conda create -n pyviztest2 -c pyviz panel=0.9.1

Collecting package metadata (current_repodata.json): done
Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): done
Solving environment:
Found conflicts! Looking for incompatible packages.
This can take several minutes. Press CTRL-C to abort.
failed

PackagesNotFoundError: The following packages are not available from current channels:

  • python_abi=3.8[build=*_cp38]

Current channels:

  • /conda.anaconda.org/pyviz/win-64
  • /conda.anaconda.org/pyviz/noarch
  • /repo.anaconda.com/pkgs/main/win-64
  • /repo.anaconda.com/pkgs/main/noarch
  • /repo.anaconda.com/pkgs/r/win-64
  • /repo.anaconda.com/pkgs/r/noarch
  • /repo.anaconda.com/pkgs/msys2/win-64
  • /repo.anaconda.com/pkgs/msys2/noarch

To search for alternate channels that may provide the conda package you’re
looking for, navigate to

https://anaconda.org

and use the search bar at the top of the page.

:thinking:

so by adding the conda-forge channel it works (and invites using python 3.8), which isn’t documented at any step before or on panel.holoviz.org.

I am not sure whether it’s an anaconda problem or a panel problem.

(NB: it works with python 3.7, the solution was adding the conda-forge channel due to this python_abi package)

1 Like

For what it’s worth, I was running into problems with a conda environment (Python 3.7) created with conda-forge and with unpinned packages. If I remember correctly, the environment was created, but I was experiencing bugs with some Panel widgets. Pinning to bokeh=1.4 fixed the problem. I’ve been sticking with conda-forge and bokeh 1.4, and everything is fine.

This is worrying since it indicates the Panel builds on the PyViz channel are still incorrect. Mind filing this as an issue on Panel?