Unlink axes

It seems like by default holoviews links axes across all plots. My plots are not related so linked axes dont make sense and I often cannot see data for 1 plot. Is there a way to unlink them and also not link them by default? I would rather selectively link them when it makes sense.

The solution to turn them off by default is this:

    hv.opts.defaults(hv.opts.Curve(axiswise=True, framewise=True, shared_axes=False),                                  
                     hv.opts.Scatter(axiswise=True, framewise=True, shared_axes=False),                                
                     hv.opts.Image(axiswise=True, framewise=True, shared_axes=False),                                  
                     hv.opts.Histogram(axiswise=True, framewise=True, shared_axes=False))

To unlink the axes of plots in a Layout, use the option axiswise=True

h=hv.Curve([ 1, 3, 2, 5])+hv.Curve([30,20,50,10])
h.opts("Curve", axiswise=True)

For the hv.Layout, there is also a shared_axes=False option

h=hv.Curve([ 1, 3, 2, 5])+hv.Curve([30,20,50,10])
h.opts( shared_axes=False)

To unlink the axes in a hv.HoloMap, use framewise=True

Alternatively, you can give your axes different Dimensions…

To set options, there is hv.Options and hv.Store which I do not use…

1 Like

Just want to say that this post solved my problem so thanks @ea42gh.

However, IMO the default behavior is extremely unintuitive and either needs to be explained in the Intro docs or should be changed. There is no mention of this behavior in the composing elements docs, where it should be prominently featured. I was very confused by the behavior shown below, which feels like a bug-- not only are the axes “linked” when they should be different according to my xlim command, but the xlim is not applied at all!:

1 Like