Zoom disappears while using datashade inside holoviews with invert_axes option

I am trying to replicate the Large data tutorial using datashader and holoviews. Below is the minimal code

import holoviews as hv
import numpy as np
from holoviews import opts
from holoviews.operation.datashader import datashade, 


def random_walk(n, f=5000):
   """Random walk in a 2D space, smoothed with a filter of length f"""
   xs = np.convolve(np.random.normal(0, 0.1, size=n), np.ones(f)/f).cumsum()
   ys = np.convolve(np.random.normal(0, 0.1, size=n), np.ones(f)/f).cumsum()
   xs += 0.1*np.sin(0.1*np.array(range(n-1+f))) # add wobble on x axis
   xs += np.random.normal(0, 0.005, size=n-1+f) # add measurement noise
   ys += np.random.normal(0, 0.005, size=n-1+f)
   return np.column_stack([xs, ys])

paths = hv.Path([0.15*random_walk(100000) for i in range(10)],label="Paths")

#No invert_axes option and displays the random walk path with normal zoom behaviour

#Zoomed result disappears when  invert_axes=True

Zoom behaviour when invert_axes=False

Zoom behaviour when invert_axes=True

As you can see the zoom behavior is incorrect when the invert_axes=True
Am I setting the parameter correctly?

Hi @carl. The invert_axes seems to be doing nothing in this case. When I tried the change you suggested, the path didn’t invert its orientation.

Hi @returncode13, Not sure why I thought that functioned have gone back and agree it didn’t change at all and your original issue stands. Bar changing the return data from the function and renaming axes (which I guess is a workable fudge) I’ve not managed to invert the axes without the issue you raise.

Sorry don’t have much more to add other than holoviews seems fine itself when inverting the axes, all seems to function as you would want, it looks like a lingering bug is being passed through when you combine with datashade.