Help! How do I get a working version of Holoviews?

I am unable to restore a working environment with whatever combination of versions of jupyterlab, holoviews, bokeh might work. @philippjfr might I ask you to comment please?

1 Like

Some possibly relevant console messages are:

  • remoteEntry.2598bb44edcc46dad172.js:1 Unsatisfied version 6.0.6 from @jupyter-widgets/jupyterlab-manager of shared singleton module @jupyter-widgets/base (required ^1.1.10 || ^2 || ^3 || ^4.0.0)
  • Failed to fetch ipywidgets through the “jupyter.widget.control” comm channel, fallback to fetching individual model state. Reason: Control comm was closed too early
  • 134.a63a8d293fb35a52dc25.js?v=a63a8d293fb35a52dc25:1 Error: widget model not found
    at f.get_model (336.ebc7a55ea1768712771f.js?v=ebc7a55ea1768712771f:1:3461)
    at w.renderModel (134.a63a8d293fb35a52dc25.js?v=a63a8d293fb35a
  • Bokeh: BokehJS was loaded multiple times but one version failed to initialize.
  • Panel: ERROR: Unable to run Panel code because Bokeh or Panel library is missing

I think you may try filing an issue. Also, if you haven’t tried, clear all output in Jupyter notebook + clear browser cache.

1 Like

Hi @ahuang11, thank you for responding.
I had tried clearing the browser cache before.

Currently, the graphs display again. What I did:

  • cleared the cache
  • stopped all running kernels in jupyterlab (this appears to be key)
  • restarted the kernel of just one notebook

I’ll report back if I figure out a reliable way to reproduce the problem,
(or if I can’t get back to a working state). Right now, I would not know
what kind of issue to file!

1 Like

Also, if you remove the first ds.hvplot call, the other plots will also disappear. Discord
Could be related.

Just keeping track of symptoms:

  • after running for several days, the problem reappeared
  • stopped all running kernels, cleared cache, restarted one kernel, to no avail
  • closed down running kernel, cleared cache, exited jupyter lab
  • restarted jupyter lab, restarted the kernel in the one open notebook: system is working again.
1 Like